树莓派64位系统安装docker

64位系统安装踩搞不少,很多apt都装不了,只能看官方有没有deb包,实在不行就需要编译安装。

可以从这里找docker的包
https://download.docker.com/linux/debian/dists/buster/pool/stable/armhf/

需要下载这三个 wget xxx

wget https://download.docker.com/linux/debian/dists/buster/pool/stable/armhf/docker-ce-cli_19.03.9~3-0~debian-buster_armhf.deb
wget https://download.docker.com/linux/debian/dists/buster/pool/stable/armhf/docker-ce_19.03.9~3-0~debian-buster_armhf.deb
wget https://download.docker.com/linux/debian/dists/buster/pool/stable/armhf/containerd.io_1.2.13-2_armhf.deb

安装顺序可以先装docker-ce-clicontainerd.io,最后才是docker。

安装containerd.io 可能碰到这种问题

dpkg -i containerd.io_1.2.13-2_armhf.deb
Selecting previously unselected package containerd.io:armhf.
(Reading database ... 93180 files and directories currently installed.)
Preparing to unpack containerd.io_1.2.13-2_armhf.deb ...
Unpacking containerd.io:armhf (1.2.13-2) ...
dpkg: dependency problems prevent configuration of containerd.io:armhf:
 containerd.io:armhf depends on libseccomp2 (>= 2.3.0).

dpkg: error processing package containerd.io:armhf (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.8.5-2) ...
Errors were encountered while processing:
 containerd.io:armhf

可以先尝试安装 apt-get install libseccomp2, 可能这里又提示:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libseccomp2 is already the newest version (2.3.3-4).
You might want to run 'apt --fix-broken install' to correct these.

那么就按提示执行 apt --fix-broken install
再次安装 dpkg -i containerd.io_1.2.13-2_armhf.deb 应该就没问题了。

添加评论
取消
*
*
*
*
勇士!消灭0条评论,这么艰巨的任务就靠你了!